TortoiseSVNでエラー発生

バージョンアップのポップアップがウザイのでアップデートしたら、BDB接続できずにエラーが出るようになりました。
Windows2k・ローカルリポジトリの話です。

— エラー内容

エラー: URL に対し ra_local セッションを開始できません
エラー: リポジトリ 'file:///D:/SVN/test.com' を開けませんでした
エラー: ファイルシステム D:/SVN/db に対して opening environment をしているときに Berkeley DB エラーが起きました
エラー: DB_VERSION_MISMATCH:
エラー: Database environment version mismatch
エラー: bdb: Program version 4.3 doesn't match environment version  

いつもお世話になっているGoogleで調べてみました。[参考]
…が、日本語の情報が少ない。。。

とにかく上記のtakeyama’s blog様を参考にして復旧してみました。

— コマンドライン版のインストール
http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=91

svn-1.1.4-setup.exeをダウンロード。(svn-1.2.0-setup.exeよりこっちの方がいいみたい)

— Berkeley DBのリカバリ

http://subversion.tigris.org/faq.html#bdb43-upgrade

引用

Normally one can simply run svnadmin recover to upgrade a
Berkeley DB repository in-place. However, due to a bug in the way
this command invokes the db_recover() API, this won’t work
correctly when upgrading from BDB 4.0/4.1/4.2 to BDB 4.3.

Use this procedure to upgrade your repository in-place to BDB 4.3:

  • Make sure no process is accessing the repository (stop
    Apache, svnserve, restrict access via file://, svnlook, svnadmin,
    etc.)
  • Using an older svnadmin binary (that is, linked to
    an older BerkeleyDB):

    1. Recover the
      repository: ‘svnadmin recover /path/to/repository
    2. Make a backup of the repository.
    3. Delete all unused log files. You can see them by running
      svnadmin list-unused-dblogs /path/to/repeository
    4. Delete the shared-memory files. These are files in the
      repository’s db/ directory, of the form __db.00*

The repository is now usable by Berkeley DB 4.3.

上記の通りやっていったら、ちゃんとインポート・エクスポートできるようになりました。

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中